Talk:FIPS Library and Android

From OpenSSLWiki
Jump to: navigation, search

Need to add a reference to "ndk-build error when trying to link with libcrypto.so" on NDK-Discuss and David Turner's comments:

<begin quote>

> So you're saying I need to add libcrypto to my source and build
> it just like I'm building everything else?

Yes, either that or find a different prebuilt of the library that
was built with a NDK-compatible toolchain.

Also, don't simply call it 'libcrypto.so'  because this will
conflict with the system library with the same name preloaded in
all Android application processes. Either link it statically
(recommended), or give it a different name (e.g.
libcrypto_myproject.so).

<end quote>