Talk:Multiprecision arithmetic internals

From OpenSSLWiki
Revision as of 07:57, 29 July 2019 by Matt (talk | contribs) (BN Library Broken Link)

Jump to: navigation, search

BN Library Broken Link

It looks like this is the documentation the first link was supposed to point to, but this documentation module is not in version 1.1.1. Since I would assume this means either the module or the interface is deprecated, what is the recommendation in this scenario where we're updating the documentation regarding a deprecated function or library? Should I keep the broken link notice and not even list it to prevent new users from using a deprecated feature, at least until we finish modernizing the documentation? Or do I add it in and simply append a notice stating the feature is part of a deprecated API?

Jflopezfernandez (talk) 06:25, 29 July 2019 (UTC)


Actually the BN API is not deprecated. It's just that there's been quite a lot of work over time on trying to improve the documentation and lots of stuff got moved around. It looks like at some point this overview page got deleted - I'm not entirely sure why. I'd suggest we could direct users to some of the key BIGNUM pages instead, such as BN_new(), BN_add(), etc.

--Matt (talk) 07:57, 29 July 2019 (UTC)