Difference between revisions of "Libssl API"

From OpenSSLWiki
Jump to: navigation, search
Line 5: Line 5:
 
* [[Diffie-Hellman parameters]]
 
* [[Diffie-Hellman parameters]]
 
* [[Hostname validation]]
 
* [[Hostname validation]]
 +
 +
== How to get libssl API to compile with it ==
 +
 +
on Debian base ( debian, ubuntu, ... ) you would need libssl-dev  : apt-get install libss-dev.
 +
 +
on Redhat base ( RedHat, Fedora, ... ) you would need openssl-devel : yum install openssl-devel
 +
 +
You can get sources directly too to compile statically over it.
  
 
[[Category:Ssl API]]
 
[[Category:Ssl API]]

Revision as of 19:37, 4 September 2014

libssl is the portion of OpenSSL which supports TLS ( SSL and TLS Protocols ), and depends on libcrypto.

This is a C api. To use it you need to include (at least) openssl/ssl.h and to link your program with libssl library.

How to get libssl API to compile with it

on Debian base ( debian, ubuntu, ... ) you would need libssl-dev  : apt-get install libss-dev.

on Redhat base ( RedHat, Fedora, ... ) you would need openssl-devel : yum install openssl-devel

You can get sources directly too to compile statically over it.